Leasehackr Calculator Not Working

Hello. Is anyone else having issues with the Leasehackr calculator? I have tried it on different browsers and it’s not loading any numbers when I input the price, etc.

Can you be more specific of what you’re seeing? What numbers aren’t loading? It’s working fine for me on Firefox on my phone.


Please see screen snapshot. Nothing updates when I fill in the data.

What happens when you fill in the selling price?


Nothing happens when I fill in the selling price :frowning:

Do you have any other missing info down below? Have you clicked into a different field after typing in the value?

Just refresh the page. This happens to me a lot but once I refresh or click the calculator button again it works

% off also didn’t populate even with the selling price.

I always tell my mom to turn her phone off and then back on. Sort of lazy, but it solves almost everything.

What kind of device are you using?

I’m facing the same issues while going to access. I also tried in a different browser but still its can’t access.

Can you provide a screenshot and instruction on how we might be able to replicate it? Trying to figure out what is causing the incompatibility.

I’ve been able to recreate it by turning JS off with an extension, which leads me to believe that something is knocking JS out under certain conditions. Under chrome I see there is a console error with adsense that’s registering as uncaught. For complete “funsies” I’ve opened the calculator in IE11, and there is a syntax error from IE standpoint and a failed AJAX call. Now depending on how IE is configured, it may stop executing all JS depending errors found. I don’t think anyone complaining was actually using IE, so it’s more of an academic conversation to see if it sparks any thoughts on what could be broken.

I had the same issue as @Ursus on when I tried on chrome (%off MSRP didn’t populate). When I switched over to Firefox, it worked fine. Thanks for the suggestion @mllcb42!

I didn’t have this issue, just pointed out what I saw on the screenshot :slightly_smiling_face: